Android is available from the Play Store. You will need a device running Android 5.0, or later and Bluetooth 4.0 or newer.


NOTE: Unfortunately, Apple has made a policy change that resulted in them removing all vape-related apps from their app store. Ghost Vapes was not singled out individually and, to be clear, this decision affects all vape companies with an iOS app. We are appealing this decision so that we can have our app relisted as soon as possible. If you would like to help, please voice your concerns regarding this policy change from Apple by publicly tweeting Apple’s Support Account at @AppleSupport and by signing our petition http://chng.it/GNX6X2YJ.


In the meantime, it's not required to have the app to operate your MV1. Here's our information on that: +MV1: Can I Use My MV1 Without the App?


How Do I Find Out if My Mobile Device is Compatible? 

For Android Users

Google (insert your model phone here) specs



For iOS Users

Google iPhone (insert your model iPhone here) specs


You can learn more about our App here!